将技术分析进行到底
提供专业的程序化交易解决方案

波浪尺指标与判断高低点的逻辑

该指标提供了一种判断高低点的逻辑,可供大家参考。


指标源码:

N:=3;//参数
A1:=REF(HIGH,N)=HHV(HIGH,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);
A2:=REF(LOW,N)=LLV(LOW,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);
E1:=(REF(LLV(LOW,2*N),1)+REF(HHV(HIGH,2*N),1))/2;
E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,999999),X1)),NODRAW;
G1:=F1>REF(F1,1)||F1=1&&REF(NOT(F1>=0),1),NODRAW;
I1:=BACKSET(G1,2),NODRAW;
LD:=I1>REF(I1,1),NODRAW;//高点
L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2)),NODRAW;
G2:=F2>REF(F2,1)||F2=1&&REF(NOT(F2>=0),1),NODRAW;
I2:=BACKSET(G2,2),NODRAW;
HD:=I2>REF(I2,1),NODRAW;//低点
/* 以上为该指标使用的判断高低的逻辑 */
DRAWLINE1(LD,L,HD,H,0),COLORWHITE,LINETHICK1,POINTDOT;
DRAWLINE1(HD,H,LD,L,0),COLORWHITE,LINETHICK1,POINTDOT;
J1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HD),BARSLAST(LD))+1);
J2:=J1>REF(J1,1);
DRAWLINE1(J2,IF(HD,H,L),ISLASTBAR,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),COLORWHITE,LINETHICK1,POINTDOT;
//高低点1/2位置
LMID:=(L+REF(H,BARSLAST(HD)))/2;
HMID:=(H+REF(L,BARSLAST(LD)))/2;
LDRAW:=LOOP2(LD,1,LOOP2(C<LMID&&REF(LDRAW,1),REF(LDRAW,1),0));
HDRAW:=LOOP2(HD,1,LOOP2(C>HMID&&REF(HDRAW,1),REF(HDRAW,1),0));
STICKLINE(LDRAW,REF(LMID,BARSLAST(LD)),REF(LMID,BARSLAST(LD)),COLORGREEN,0);
STICKLINE(HDRAW,REF(HMID,BARSLAST(HD)),REF(HMID,BARSLAST(HD)),COLORRED,0);

上证指数2015年1月1日至2015年6月30日的K线效果图:

5010.1

 

 

 

未经允许不得转载:文华程序化 » 波浪尺指标与判断高低点的逻辑
分享到: (0)

评论 1

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
  1. #1

    文华赢顺 通不过  提示35、36行 有误

    悟道4周前 (07-24)回复

横冲直撞 一直到最远方